Hello Guest, if you read this, it means you are not registered. Click here to register a few simple steps, you will enjoy all the features of our Forum. Please note that nicknames are prohibited lewd or meaningless (no numbers or letters at random) and introduce yourself in the section for you to meet our community.
Shared IP address for nobody - Blogs - GOZEN Host Forums
View RSS Feed

Nick

Shared IP address for nobody

Rate this Entry
by , 11-27-2014 at 11:56 PM (3508 Views)
When you have more than one IP's bind to your server, you might see under your cPanel/WHM more than one shared IP's even though you might have not configured any resellers (some like to configure shared IP's for resellers).
Actually it might look something like this:

Shared IP address for root. IP #
Shared IP address for nobody IP#


Truth is we only need one share IP for root, in addition in /usr/local/apache/conf/httpd.conf you might have the following lines:

# WHM DOMAIN FORWARDING VHOST
<VirtualHost MY-IP>
ServerName MY-IP
ServerAdmin root@localhost
DocumentRoot /dev/null
ScriptAliasMatch .* /usr/local/cpanel/cgi-sys/domainredirect.cgi
</VirtualHost>
What's the cause for this ? The answer hears to Domain Forwarding that you have enabled and there's an easy way to solve it.
Navigate to WHM -> DNS Functions -> Setup/Edit Domain Forwarding and set it to disable.
Rebuild/Restart Apache and your are ready !!
Attached Thumbnails Attached Thumbnails blogs/nick-309/attachments/41-shared-ip-address-nobody-domains_forwarding_whm.jpg  

Submit "Shared IP address for nobody" to Digg Submit "Shared IP address for nobody" to del.icio.us Submit "Shared IP address for nobody" to StumbleUpon Submit "Shared IP address for nobody" to Twitter

Comments