WordPress 4.0.1 is now available.

This is a critical security release for all previous versions and we strongly encourage you to update your sites immediately.
WordPress versions 3.9.2 and earlier are affected by a critical cross-site scripting vulnerability, which could enable anonymous users to compromise a site.
Also version 4.0.1 does address these eight security issues:


  • Three cross-site scripting issues that a contributor or author could use to compromise a site.
  • A cross-site request forgery that could be used to trick a user into changing their password.
  • An issue that could lead to a denial of service when passwords are checked.
  • Additional protections for server-side request forgery attacks when WordPress makes HTTP requests.
  • An extremely unlikely hash collision could allow a user’s account to be compromised, that also required that they haven’t logged in since 2008 (I wish I were kidding).
  • WordPress now invalidates the links in a password reset email if the user remembers their password, logs in, and changes their email address.


Version 4.0.1 also fixes 23 bugs with 4.0, and introduces two hardening changes, including better validation of EXIF data we are extracting from uploaded photos.
How to update if you don't have auto updates enabled:


Download WordPress 4.0.1 or venture over to Dashboard → Updates and simply click “Update Now”.